sshdはやっぱりデフォルトポート使わないほうが良いな・・・

サーバー更新した時に他の対策も入れたんでポートをデフォルトに戻してみたが・・・
あまりにもアタックが多い、かすりもしない攻撃でもログ多すぎてウザイ。
ということで以前のようにポート変更、
それでもたまにポートスキャンで見つけて叩いてくる奴がいるのでfail2banも必要ではある。


そりゃああんな状況じゃノーガードで使ってたらすぐに乗っ取られるわ、世の中にやられてるサーバーがいっぱいあるのも納得。

ついでにfail2banを入れてサーバーの防御力も上げてみた

以前はblocksshdとか使ってたけど最近は動かなくなってたのでポート変更で対応してた、色々やるついでに fail2ban を導入して smtps の防御も追加。

fedoraの場合は簡単に導入できる
dnf install fail2ban
systemctl enable fail2ban
vi /etc/fail2ban/jail.local
ファイルには以下を記入
[sshd]
enabled = true
bantime = 600
findtime = 10
maxretry = 1

[postfix-sasl]
enabled = true
maxretry = 10
findtime = 60
bantime = 1800

ここまで
systemctl start fail2ban
完了

設定値はまだ結構適当なので運用しながら調整していく。

4×4 BOX 4800Uを買ってサーバーを入れ替えた

しかし届いたときはあまりの軽さにびっくりした、
私が今まで買ったPCの中でも一番軽い、もう少し重くて大きいものだと思っていたのに、めちゃくちゃちっさいし軽い。
面積は10インチタブレットよりも小さい。

JEDEC準拠のDDR4-3200 8GBを2枚、
PLEXTERのPX-512M9PGN+(NVMe SSD 512GB)
あとはロジテックの無線キーボード、
マウスはあんまり使わずに放置してたロジテックの無線があったのでそれを使う。
Unifyingの設定はWindowsでやった、LinuxからもできるらしいのだがWindowsでやったほうが簡単だし。
4Kディスプレイを買って余ってた飯山のWUXGAがあったのでそれとDP接続。

ちょうどFedora 34が出たばかりということもあるのでこの際ゼロから構築しなおして設定とかデータだけ移動することにした。
なにしろ初代Fedoraの頃からずっとアップグレードで使っていたのでゴミが溜まりまくってたり、一部設定とか形式古くて更新しろと怒られたりするのでw

パワーマネージメントのせいかログインプロンプト出て数秒で画面がフェードアウトする。
ディスプレイのメニューボタン押すと復活するのでどうやらディスプレイ側の機能で消えてるらしい、Linux側で省電力系の機能をオフにしたりいろいろやっても解決できず・・・
まぁせっかくAPUだし使ってみようということでGUI起動に設定してみたところ問題なく動作してる。

最新OSだけあって2.5GbEもデフォルトで認識してる、無線LANのAX200もそのまま認識、音も鳴ってる、ハードウェア関連は何もしなくても全部使えてるっぽい。
Vega8ももちろん認識されてる、AMDのドライバはカーネルにマージされてるので楽ちん。

dns、web、メール、dhcpdがほぼ問題なく動かせるようになったので完全に入れ替え、あまり使わないデータ類はまだ旧サーバーにあるので暇を見てコピーしていく感じ。

さすがZen2APU、SandybridgeなXeon 1260Lに比べてクロックめっちゃ低いしTDPも20Wくらい低いのにブーストしなくても性能は倍以上、CPUの処理性能は大幅に上がったので大満足、
SSDのほうはベンチしてみてもそんなに速くなってない感じ、
SATAからNVMeだからもっと差があるかと思ったんだけどな。

RADEON 6900XTのドライバが急におかしくなった

昨晩シャットダウンしたところまでは特に問題なく動いていたのだが・・・
今朝起動したらいきなりクソデカ文字画面、
何事!?デバイスマネージャを開いてみるとRADEONにマークが、
「デバイスを移行できませんでした」とかいうエラーが出ている。
マジで何もしてない、もう訳がわからないよ。

で、色々と試してみる。
0.主電源OFF、数十秒放置→効果無し、高速スタートアップ的なモノは全て無効にしてあるから効果ないのはわかってたよ、とりあえずお決まりだからやってみただけ。
1.ドライバを入れ直し→効果無し
2.別なバージョン(WindowsUpdateのものも含む)のドライバをいくつか試してみる→効果無し
3.ReSizeBarをOffにしてみる→効果無し
4.別なドライブにインストールしてあるだいぶ古いOS(X399の時移植したNVMeSSDに緊急用としてそのまま残してた奴)で起動してみる→WindowsUpdateのドライバで問題なく認識した

ここでOSが原因と言う事がわかった、6900XTの故障じゃなくて良かった、今修理に出したらいつ戻ってくるかわからないし。
予備の5700XTとVega64あるから使えなくなると言う事は無いけども。

と言う事でOS修復作業に。
1.定番のDISM/SFCコンボで効果無し、破損ファイルはなかった。
2.chkdsk、問題なし・・・
3.直近のWindowsUpdateをいくつかアンインストールしてみる→効果無し

最後の手段、禁断のOS上書きインストールだ!
もの凄い時間かかるのでやりたくはなかったのだが、もうこれくらいしか手段が無い。
これで午前中潰れちゃったよ、これで治らなかったらどうしたものか。

何度か再起動、1時間くらいひたすら待つ・・・
あれ?なんか起動早くなってないか?
今まではログイン後に数秒間ブラックアウトしてたんだがそれがなくなった!
で、ドライバはちゃんと動いてるのか?ドキドキ

ミッションコンプリート!

無事動くようになった、やはりOSがおかしくなってたみたいだな、
しかし一体なにがどうなってこうなったのかがさっぱりわからない、
昨日は普通にDyson Sphereを建造してただけでおかしな事はしてないはずなのだが。

まぁ治ったからいいか、なんか若干動作が軽くなったような気もするし、
プラシーボ効果な可能性はあるけど。

いつの間にかRyzenmasterがHyper-V有効でも動くようになっていた

テレワーク時にHyper-V仮想マシンで作業しているのでRyzenmasterを使うのにいちいちバッチのショートカット叩いて再起動かけるのも面倒だった、
そういや5000シリーズ出たからなんか更新されてんだろうかと入れてみたら普通に起動してるし。
これでいちいち再起動しなくても良くなった。

Fedora 32→33へ、今回は二か所

アップグレード方法は公式で。

network-scriptsでpppoeを設定している場合、NetworkManagerでやってる場合はそのままでいいのかな。
rp-pppoe.soのパスが変わってるので ifcfg-ppp に書いてあるパスを変更
LINUX_PLUGIN=/usr/lib64/pppd/2.4.8/rp-pppoe.so
インターフェースを再起動、ifupは非推奨だからNetworkManager使ってねみたいな警告出るからそのうち変更するか・・・

Dovecotのdh.pemでエラーが出るので
sudo openssl dhparam -out /etc/dovecot/dh.pem 4096
これは結構時間がかかる。
終わったら。
sudo systemctl restart dovecot
で完了。